Hoppa till innehåll

  • Logga in via Facebook Logga in via Twitter Logga in via Windows Live Log In with LinkedIn Log In with Google      Logga in   
  • Registrera dig nu!

Problem med autoredirect mot Cisco ISE/WLC på Iphones


  • Please log in to reply
Inga svar i detta ämne

#1 neonodia

neonodia

  • 292 inlägg

Skriven 06 December 2017 - 16:28

Jag håller på att sätta upp ett nytt trådlöst nätverk på företaget.
Vi kör med WLC 3504 med firmware 8.5.105.0 och har en ISE 2.3 versionen.

Vi har 3 ssid på seperata nät,där vi kör radius mot prod nät, samt mobil nät
och så har vi en gäst portal som vi satt upp.

All nättrafik är fungerande på alla 3 ssid.  Problemet vi har just nu är att autoredirect när man försöker ansluta sig mot vårt gästnät inte fungerar på IOS enheter, samt vissa inofficiela android telefoner.
På en dator när man ansluter sig så händer antingen följande
  • På en windows burk så öppnas automatisk en webläsare och du kommer till portalens registrerings sida, samma visa på en officiel android telefon, du ansluter dig och automatisk öppnas en browser och du åker till portalurlen.
  • På en Mac så får du en liten notis om att du behöver registrera dig och klickar du på den så kommer du till urlen för registrering, (Lite notis under webläsaren på MaxOsX)
  • Dock på en IOS enhet, Iphone 5. 7, 7 plus , Ipad. Med alla olika ios versioner så händer ingenting när du ansluter dig till nätet. Du blir ansluten till Wifi nätet men inget autoredirect. Försöker du surfa och är på https url så får du endast denna sida kan inte visa. OM du försöker gå till en vanlig http sida så blir du redirected till korrekt url för registrering.

Jag har felsökt detta och blir snart tokig. Det verkar som om det funnits tidigare buggar som skall vara lösta och jag har testat diverse saker utan resultat.

Jag har aktiverat Url ACL accesslist och gjorde olika regler utan resultat.
Dubbelkollat så att dhcp adress asignment required är ibockad
använt captive portal bypass etc etc.

Nu sliter jag snart av mig håret.  Någon som har stött på liknande och löst problemet?




0 användare läser denna tråd

0 medlemmar, 0 gäster, 0 anonyma medlemmar